Back to overview
Resolved

Ongoing issues with SMS sending

May 27, 2026 at 9:00am UTC
Affected services
Mjog

Resolved
May 28, 2026 at 4:32pm UTC

The root cause has now been identified and a fix has been implemented.

This was an unprecedented incident that required significant engineering effort to fully identify, address and remediate the underlying issue.

Our teams have been working continuously to restore normal service as quickly and safely as possible.

We can now confirm that the issue has been resolved and SMS delivery should once again be functioning normally across the platform.

Any messages that were attempted during the outage period will begin to gradually trickle out from the queue as the backlog is processed.

We appreciate your patience and understanding while we worked through this issue, and we apologise for the disruption caused.

Updated
May 28, 2026 at 11:07am UTC

The team are continuing to investigate the root cause but it has yet to be determined.

This is an unprecedented incident and our engineering team has been working around the clock since the issues were first detected

Updated
May 28, 2026 at 8:04am UTC

The team are continuing to investigate the root cause today and we will provide further updates shortly.

Updated
May 27, 2026 at 9:04pm UTC

The team are continuing to identify the root cause of the issue affecting the delivery of SMS messages. The Engineering team have been working tirelessly to identify the root cause.

Further updates will be provided tomorrow.

Updated
May 27, 2026 at 5:58pm UTC

The team are continuing to identify the root cause of the issue affecting SMS delivery within the Mjog platform.

At present the root cause is currently still unknown but the Engineering team are working extensively on a resolution.

Updated
May 27, 2026 at 2:06pm UTC

The team are continuing to investigate the ongoing issue with SMS messages not sending from the Mjog platform.

At this stage, the root cause has not yet been identified. The team are working extensively to investigate and identify the underlying issue as quickly as possible.

Updated
May 27, 2026 at 11:00am UTC

Our engineering team are continuing to investigate the ongoing issue with SMS delivery and working to identify the root cause.

Created
May 27, 2026 at 9:00am UTC

We are currently experiencing ongoing issues with SMS sending, with messages queuing instead of being delivered as expected.

Our engineering team is actively investigating and working to identify the root cause. We will provide further updates as soon as more information becomes available.